Gold Cart 2.9.8 Release and SagePay Info

Gold Cart version 2.9.8 is now available for download on Your Account page if you have an existing account on wpecommerce.org If you don`t have an account yet, use the Account Migration page to move your old Gold Cart API info into a brand new account.

Below is the changelog for the 2.9.8 version:

* Update: BluePay to send cart items in the comments field.
* Update: SagePay gateway updated to protocol 3.00 ( Effective July 31st 2015 )
* Update: eWay now uses Direct Connection and client side encryption of the credit card fields. No need for PCI Compliance
* Update: Authorize.net 2.0 now sends the State field too
24 responses... add one

Trying to update my Gold Cart to 2.9.8 from 2.9.7.8 and I get this error:
Parse error: syntax error, unexpected T_STRING in /home/content/51/2245351/html/pelicanink/wp-content/plugins/gold-cart_plugin-2.9.8/merchants/eway.php on line 59

Make sure you have PHP 5.3 running on your server.

Sorry, but I’ve just got the same error while upgrading 2.9.7.8 to 2.9.8. Then every pages where KO with this error. I was obliged to move back to previous version of the plugin. PHP 5.4 is running on my server. What’s wrong? Please help, thank you.

Hi Did you resolve this?
I’m having the same issue exactly. Running Version information: 4.3.7. appreciate any help

Hi – have updated my gold cart and the Sagepay update seems to work, which is what I was after, however the live search no longer works, and the plugin seems to be adding text instead of images to my product-page thumbnail gallery… is it a work in progress?

Could you post a Premium Support topic and we will investigate.
Thanks

I can’t work out how to do that, sorry! I have got around the problem by just copying the new sagepay gateway php file to the old version of gold-cart. Please could you remove my email address from public display in the post above?

Even though my purchase is current, there is no download shown in the Download section of my Account. This means that I cannot upgrade to the latest version of Gold Cart

I’ve upgraded to this on my site, but my SagePay dashboard still thinks I’m on an old version, are there any additional actions which need to be taken?

Ta

Hello, I’m having exactly the same issue as JD on this thread. Could you help me also please?

Hi, we have a new client that has a website that is using Gold Cart 2.9.2. We want to purchase the upgrade to 2.9.8, but just wanted to make sure that it will be compatible with Sage 3.0. Please can you respond and let me know. Also one last thing, do we need to run the latest wordpress for it to be compatible also. Kind regards, Matt.

Hey there,
You don`t have to purchase Gold Cart again. You can download it on your account page and if your purchase is older use the Migrate Account form first then redownload.
The 2.9.8 version onwards is compatible with SagePay 3.0
Regards
Mihai

Hi,
I upgraded this site to 2.9.8 as they use SagePay and the checkout page now white screens. How do I solve this problem? The site is using WP Ecommerce 3.8.9.4 and the server is running PHP 5.3.3.
Many thanks.

Hi,
I resolved this problem. The server error logs showed that it needed to PHP mcrypt for the software to work.

Hi,
My wordpress installation is telling me that there is a new version of Gold Cart available (2.9.9) and gives me a link to download it…but there is no 2.9.9 there, just the version I already have installed.
Please can you let me know where the download link is?
Thanks,
Martin

The latest version is the zip called gold-cart.zip
Try that one.

Thanks. The download file says 3rd May 2015 and is called gold-cart_plugin-2.9.8. I already have this version.

Hey there,
Can you login to the YOur Account page and check again ?

Hi.
Just checked again and still shows 2.9.8.
Sorry.

My wp account tells me that Gold Cart 2.9.9 is available for download, but when I try to download it does not automatically do it, but it asks if I want to save or open the zip file. How do I download the latest Gold Cart version?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.